PDA

View Full Version : Glitched Achievements


CandidGamera
12-05-2008, 03:50 PM
So I won an Economic victory, playing Beta Centauri on Deity level as the English, and never changed government types but didn't get the Absolute Power is Kind of Neat achievement.

Then I played a normal game, on Chieftan difficulty, and got my capital city up to almost 400 Culture per turn, yet didn't get the Universal Brotherhood of Man achievement.

I did notice that my Xbox Live connection dropped during each game, but that shouldn't stop an Achievement from unlocking, right? It just seems really strange that two Achievements should fail to unlock in the same session.

Johnny3ng
12-06-2008, 05:57 PM
I have just had the same problem Absolute Power is Kinda Neat achievement has not unlocked for me?? No Fair!!

Rainman Andy
12-06-2008, 10:44 PM
I had the same problem, did it 4 or 5 times but no achievement. There is an old post on here which explains that it has to be done on despotism (even though the guide says otherwise). I tried it on despotism and got it first time.

kewljoe
12-17-2008, 12:12 AM
I tried the strategy of beta centauri scenario on emperor (whatever comes after king) and used the greeks (they start w/ depotism) and it unlocked it for me.

Opopanax
01-14-2009, 07:33 PM
Any of the civs that start with a different kind of Government don't count for the achievements, has to be depotism the whole time.