PDA

View Full Version : Problems


Betrayal
07-08-2009, 03:54 PM
Hey there guys,

I've no idea if there is already a thread, or a fix for this in such thread as I have not been searching. I'm kinda desperate right now.
Okay, so, I get home from school, and buy the full game of Battlefield:1943. I thought it looked awesome from all the trailers, and were a fan of their other games. I couldn't wait for it. So, I go to play online, (I have an EA Online account), put in my e-mail address and password, and, it says an error message. This reads:
"Your Gamer Profile does not have the correct permissions to access Xbox Live functionality."
This exact same thing happened with LOTR:Conquest.
I've been searching around in Google, and it's thrown nothing up, so, I thought I'd come to you guys for help. This is a online game, it defeats the object of buying it if I can't play online.

Thanks.

EDIT: Also, my connection is Open and there are no restrictions.

Psymox
07-08-2009, 04:02 PM
It's your xbox live settings that are at fault. I had similar trouble with battlefield 2 on the console.

Either use the xbox dashboard and go to account management to change the online settings for that account... or go to xboxlive.com and sign in and use the options there. I think thats what I did.

i'll get back to you.

Betrayal
07-08-2009, 04:10 PM
It's your xbox live settings that are at fault. I had similar trouble with battlefield 2 on the console.

Either use the xbox dashboard and go to account management to change the online settings for that account... or go to xboxlive.com and sign in and use the options there. I think thats what I did.

I'll get back to you with more info, i'll take a look.

Alright, thanks.
I'm being forced to play the tutorial over and over. It's getting slightly tedious.

Psymox
07-08-2009, 04:13 PM
At first I thought it was the member content settings, you need to turn to, Everyone.

But it sounds like it's thinking your account is Silver and not Gold. Assuming you do have a Gold subscription, try moving your profile from your hard drive on to a memory unit and back again. If not, try deleting your profile and recovering it.

EDIT: There are also family Settings on your dashboard, should give them a once over and make sure all are set to allow.

Betrayal
07-08-2009, 04:17 PM
I have a Gold account. I'll try some of these things, thanks, I'll get back to you if it does/doesn't work.

EDIT: Member content is on Everyone. Attempting moving it.