PDA

View Full Version : Achievement Icons Not Appearing in Games Library


Taiyz
07-11-2009, 07:33 PM
Whenever I view this game in the Games Library, all of its achievements are merely trophy icons. Unlocked achievements are grey trophies, and locked achievements are normal (the same icon as before but with a lock icon in the corner.)

When I view the achievements anywhere else, such as my profile accessed from the Dashboard or my games list from the Xbox Guide, the achievement icons appear correctly.

Has anybody had this problem with any other game? How can I fix it?

Or is it just another issue with the game itself?

Spectre L37
07-11-2009, 07:57 PM
I have the same problem.

Xraye
07-11-2009, 08:09 PM
Yep its the same for me. Don't know why it is happening though.

Pashos
07-11-2009, 08:15 PM
Looks that way for me to. It doesn't bother me though.

Nevander
07-11-2009, 10:01 PM
I have the problem too and it's very annoying with me being a perfectionist...

FinTacular
07-12-2009, 08:28 AM
Yup, me too.

MisterSquidward
07-12-2009, 02:36 PM
yeah its the same for me too!

-chrisluvshacks-
07-15-2009, 08:51 PM
the same thing with monkey island

MarcoPolo360
07-15-2009, 09:34 PM
I haven't really check lol as long as i have the gamerpoints for it still i'm happy

SoloEXE
07-16-2009, 08:15 AM
The same thing occurred with Bionic Commando for me.
This usually happens because the game is either extremely new [the case with BC] and thus the system is still being worked, or there are some kinks with the game as of now.

I'm not sure on this, but I'm pretty positive.

MediumMelanin
07-17-2009, 04:32 AM
yeah, I can't see them either, but I know I have them =)

OctagonQontrol
07-18-2009, 12:40 PM
http://www.xbox360achievements.org/forum/showpost.php?p=2174341&postcount=17

He solved it...

Elit3 m0nkey
07-18-2009, 03:59 PM
http://www.xbox360achievements.org/forum/showpost.php?p=2174341&postcount=17

He solved it...

The problem is that most if not all of us (I am assuming by the way) use a hard drive. I have never even held an xbox 360 memory card.

Topic: Noticed this too, not important but annoying.