PDA

View Full Version : Horrible lag or a bug?


Rifle Elite
07-13-2009, 06:07 PM
Just played a game of Battlefield and something weird happened. Game started, I entered a tank as usual and I flanked an other tank. Im sure I shot him about 2 or 3 times in the rear (red circle appeared indicating a hit) the coward then drove away from the fight. Due to the distance I couldnt get close enough to him to finish him off. When he got past a hill he stopped so that he could get a shot at me. Thats what happened. He shot me. I shot him an other time, and then he shot me a second time and destroyed my tank. Ver, Very weird! Im sure my tank was in perfect condition yet he destroyed it in 2 hits while I couldnt destroy his tank in 4-5 hits. Plus both his shots were fired at the armorplates at the front of my tank, while I shot him 2-3 times in the weaker rear.

I didnt experienced any lag during that game. So is it possible the damage done by tanks is just bugged and the damage they do is random?

Sorry for my grammar, English isnt my native language

PS before people are gonna say ''get over it'', I dont care if I die once. I just dont like it when I get killed while in my opinion I really deserved to get the kill instead

A Satyr
07-13-2009, 06:12 PM
Ive seen this quite a few times

Elit3 m0nkey
07-13-2009, 06:27 PM
It is possible that he only got hit with the splash damage. Were they direct hits? If they weren't that might of been the reason you couldn't kill him.

Rifle Elite
07-13-2009, 06:40 PM
Im pretty sure those were direct hits

Blastvader
07-14-2009, 04:43 AM
http://penny-arcade.com/images/2009/20090710.jpg

MarcoPolo360
07-14-2009, 05:00 AM
It does matter where you hit his tank. You hit anywhere near the front you have a very little chance of killing it within 2 or even 4 shots. If you want to kill the tanks aim at the engine compartment. If the tank is already damaged a tiny bit it will take as little as 1 shot.