View Full Version : Stuck on Airfield. Please help

Kai Tetley
08-23-2009, 10:35 AM
Okay. I've used my 'Veil Shield' to go through the moving electric conductors. Now I'm stuck behind a force field and I can't figure out how to get passed it. I'm on a balcony over looking a bunch of people entering a zepplin or something. The game is telling me to drop the zepplins.

Any help would be great.

08-23-2009, 11:20 AM
Just use you shield again to get through the force field, I think its right D-pad, I was stuck there for a while myself but eventually got through.

Kai Tetley
08-23-2009, 11:38 AM
Thanks. I'll try that. I'm sure I tried that and it failed. Maybe the game is tempramental ;)

08-23-2009, 07:15 PM
Hey Kai!
What's up bro?
I think that's the part where you use Empower to be able to shoot through the shield and then shoot the red explosive barrel and it will blow up the shield generator and let you through.
I just beat the campaign so if you need anymore help with it, feel free to ask man.
You up for boosting more later today?

09-13-2009, 11:26 PM
Im in the same situation, stuck with barrier and this switch, barrel and antiveil-generator on the other side:

But what if you don't have this thing EMPOWER. I haven't got it yet (or maybe been lazy finding it).
Im stuck, and shield don't work (maybe iv'e been lazy updating shield)

Laziness finding tomes and buying updates shouldn't lock up the storyplay...
Any idea how i can solve this lockup?

Anything from solving the situation without empower to finding empower or using noclip(pc/console) is great help!


09-17-2009, 06:48 PM
Obviously i was lazy, because i solved the problem with shield and grenade (no problem)
But it's the thing with the zeppelin barrier. Here it's big no no without empower.

HOW? :uzi: :locked


Where can i find empower?
Is it possible to repay without any fuckups (heard about the replay bugs)