View Full Version : Having trouble loading the game [Solution]

12-24-2009, 02:13 AM
If you are using Windows Vista or Windows 7 you may find that this game won't load for you. I would suggest trying the following out as I had the same problem and used this to fix it.

Step 1: Find the directory which World of Goo is installed in, most likely C:\Program Files\2DBOY\WorldOfGoo.

Step 2: Find the WorldOfGoo EXE Application file (the one with the Goo Icon) and right click it. Click Properties

Step 3: Click the Compatibility tab and turn on "Run this in compatibility mode for:" and then select Windows NT 4.0 (Service Pack 5) from the dropdown box.

Step 4: Tick the "Disable Visual Themes" and the "Disable Desktop Composition" checkboxes and then click Apply or OK.

Step 5: Try opening the game again and you will notice the theme might switch to Vista/7 Basic but at least you should be able to play.

If this method doesn't work for you I apologize but it worked for me so perhaps it's worth giving it a shot.

12-28-2009, 05:22 AM
no luck, still cant run it...

12-28-2009, 10:50 AM
It's not the fact that it's having issues with Vista, they fixed that in the 1.3 version that the GFWL game is, it's the fact that the launch of GFWL client screws with WoG's asset loading as it loads fine when you disable the GFWL launch settings. It seems that they just can't play nice with each other.

The Pants Party
12-28-2009, 01:30 PM
Also can't get this to work unfortunately. Played 8 levels to OCD and then took a break, when I came back nothing. The above fix doesn't solve it.

Does anyone know if there is indeed a patch on the way from the developer, or is that just a rumor?

12-30-2009, 08:40 AM
I'd assume they'll get a patch up once the holidays are over. As much as I want to play this wonderful gem of a game right now I can totally understand why we don't have a patch yet.

Yungstar 2006
01-04-2010, 01:08 PM
this worked for me.