PDA

View Full Version : Xbox Live Problems


Hobo Sniper
12-27-2009, 09:08 PM
Finally set up my new Xbox Elite today, to find that my Xbox Live is not working properly, the router model is Belkin54g, i've had it for years with no major problems, however my friend also has a belkin modle router not the exact same one and he is also on Virgin Media like me. He has been experiencing issues such as disconnections and Xbox live being slow in general and signing in issues. I have not had my xbox for about 3 weeks and today i have also been experiencing problems such as signing in, it will often say "Problem occured while signing in...etc" and when going into my friends list it will not properly load up friends or when looking at download history it will say, cannot retrieve information, but party chat seems to work fine and the dashboard is not missing anything.
I would appreciate if anyone who is also experiencing problems to post, or if somebody knows why? Thanks ;)

davhth4
12-27-2009, 09:11 PM
I use a belkin extender and it works fine but Im with aol. If no one can help maybe try contacting your ISP.

Hobo Sniper
12-27-2009, 09:15 PM
I use a belkin extender and it works fine but Im with aol. If no one can help maybe try contacting your ISP.

Hmm...yeh well ATM it seems to be a service provider issue, because its funny how both me and my friend, both experiencing same probs with xbox live are on virgin media... :L

veece16
12-27-2009, 09:15 PM
There's not any problem with your router at all, it's all these 5 and 6 year old kids that got any xbox for christmas and play halo and Cod all day and fuck up the connections. Or it could be your internet provider that's been having problems.

Hobo Sniper
12-27-2009, 09:31 PM
i think its a ISP problem but are you on virgin media?

littlemissymoo
12-29-2009, 12:27 AM
I am on virgin media and so is my mate. In past 48 hours playing on live with him has been terrible Even plays up with party chat. Game is jumpy, glichy etc. Keeps crashing etc. Can't stay in chat for long before dies even when my mate was hosted on another server he had same issues I had none. It's got to be a problem with them right?