PDA

View Full Version : Yet another Glitched achievement (emblem)


GinjiX
07-23-2010, 12:53 PM
I read through the whole sub section concerning glitched achievements and all that.
So far i have 970/1000 and the only one missing is the emblem achievement.
I did a check list, a double checked it and have all 20.
I replayed the final mission over 3 times now (by choosing to resume and not from the mission list) and still no achievement.
I cleared cache, played without the update and still nothing.

I have yet tried to finish the final mission on hard mode (i already did before unlocking the outfit achievement).
So i'm going to do this now, but besides trying hard mode, is there anything i'm missing?

EDIT : Well i did it on hard again, no achievement. Did mission 8 through 9 and finished 9. No achievement.
I'm out of options here.

cra
07-24-2010, 01:11 PM
sorry to hear that and it's the first time I've read about this glitch. Guess you tried doing mission 9 via mission select as well?

If you can't unlock it, I'd suggest trying again on another savefile...another point is that I don't know if the latest retail version( I assume you just bought it) is already a patched version or still the one I played in 2009. If it is the same buggy version I had, try playing it without patching it when asked.

Hope that helps as I don't know more ways how to possibly unlock the achievement.

GinjiX
07-26-2010, 12:15 PM
Yes, i've already mentioned that i've played it without the update by clearing the cache.
And i bought my copy on launch, i just saved the achievement hunting for later ( It's always a great incentive to go back to a game :P).

I guess my final option is to choose the mission from the mission list.
If the issue still persists, i'll have to live with the ugly 970 :(.
Thanks anyway cra (and thanks for the guide).

I'll report if there are any changes.

cosmic
10-07-2010, 07:57 AM
hi there,ive read of problem about the emblem achievement,im sorry to say that i dont have the answer for you im afraid!! but im wondering weather you have any ideas why and how i can unlock the emblem:love!!! using 1 sword throughout a mission achievement im missing,but im sure its not tied,and of course the emblem achievement.any ideas why it hasnt unlocked!!!?just to note all other achievements have been unlocked just to note!! cheers