PDA

View Full Version : Glitch causes me to loose Tomb Raider Achievement


Daluca 47
08-29-2010, 12:07 AM
Ok so i was clearing the game out and grabbing all the weapons, relics, artifacts and power ups and i worked my way up to the level 'Flooded Passage' so i did my speed run then the run for score and collectables. I destroy all the hidden urns for the ammo upgrade and it doesnt give it to me. I've retryed the level and redone it about 3 times and its still not unlocking. It says ive completed the challenge but not got the upgrade.

Can anyone help me out or am I going to have to start a new game?

http://img265.imageshack.us/img265/4979/dscf1538x.jpg (http://img265.imageshack.us/i/dscf1538x.jpg/)

Whiistler
08-29-2010, 10:41 AM
You're missing a pick up. The boxes down the bottom are things you actually pick up in the level and not to do with the objectives. Use the guide on here and you should be able to find it pretty easily.

ChArG1nMaLAZ0R
09-04-2010, 12:06 PM
that pickup glitched on me too. dont worry about it health and ammo do not count towards the achieve

Daluca 47
09-26-2010, 07:31 AM
Yea i got the achievement in the end but still havent got that pick up haha, owell this is xbox360achievements.com not 100% game stats.