PDA

View Full Version : Play Issues


Fishman
10-30-2010, 06:01 AM
During this DLC (and only this DLC/game) it would skip, lag, and there was some delay about every 30 seconds to minute. The game would just freeze for about 3 seconds. I would hit somebody with my sword, the damage I dealt would come up, but their health bar wouldn't go down for like 3 seconds. Same as the last problem except the damage I dealt wouldn't show, it was like I was just hitting the air (but it would make the striking sound). I would go to a dead body, press "A" to loot it, but it would take like 5 seconds for the menu thing to pop-up. When I used the Ogre I would do the stomp attack, he would jump up and land, but it took like 5 seconds or so for the attack to do any damage. So, those are a few problems I had. They didn't happen all the time, but quite frequently.

I tried having the DLC installed to my HDD and my flash drive, that didn't matter. I'm going to reinstall it and see if that helps. Anybody else experience this?

ADenton109
11-23-2010, 04:51 PM
I had the same problem, every time something new was going to happen it would freeze and then go really slow, my attacks would not count for a few seconds then they would start hitting. Was very laggy.

UnleashTheCASEY
12-08-2010, 03:19 PM
I had no issues with it except after the first playthrough. On that one, I enthralled the wrong ogre and had to reload and it didn't like that very much. No issues after that.

Scotty
01-01-2011, 05:12 PM
this is happening now on mine. its very annoying as im trying to get the enthrallng cheevo and i have to step back after every hit for the damage to register, at which point some punk comes in and steals the kill. its a dissapointing DLC this which is unfortunate as its the only one thats had problems with it, but was one of the best ideas.