PDA

View Full Version : Town Fails to Load


VinasErgoth
12-05-2010, 07:34 AM
I didn't exactly know what to search for this, so I'll apologize in advance if this has been discussed elsewhere.

I've been playing as my sim family for well over 25 ingame weeks now, and my main sim is almost maxed on everything and my home lot is worth over 200,000 simoleons.

I sent my sim out to 'Art's Feng Shui Garden' in order to catch some more Angelfish, by way of his car (Travel > ...). But then when I pressed :xbut: to view the area, it flashed the loading screen for a split second then went back onto the town map.

"Odd," I thought, "I'll just go back to live mode then." well apparantly my town is broken now. No matter where I go, none of the buildings or surroundings are loading properly. Here's a list of things I've tried to resolve the matter.
Start > Quit Game > Play > Continue
Guide Button > Dashboard > Reload game > Continue
Delete installed game > Reload > Load > Choose file
None of these have worked in fixing my town. I'd be crushed if I had to lose everything I've worked so hard on (my home lot especially!), and I'm still holding on to this being fixable.

Here's a picture to show you what I mean. Sorry for the quality, but it was taken with my phone.

http://i13.photobucket.com/albums/a257/Telekinetik/SP_A0148.jpg

tl;dr: My town is broken and won't load properly. Any idea how I can fix it?