PDA

View Full Version : Failing Quests :(


JONBLEACH
02-01-2011, 04:21 AM
So i guess when you fail a quest your screwed.
I already failed 2 quests because they were timed and i didnt know you couldnt redo them at the tiime.

The Rustlers Run - need a horse to get to the waypoints or whatever, i couldnt find my horse so i failed that quest. Located in Bayan. I was working on a quest called Starvation but i needed to finish that horse thing 1st. So now in my log under Bayan i have those 2 quests unable to complete them.

The second failed quest was for one of the Guilds that i got from a bulletin on the Ashos Island, I needed to kill Necris(skeletons) in a time limit to save a mage prisionor. I thought i killed everyone but then there was 1 left that was glitched into a wall.

And the best thng is the quests dont tell you they are going to be Timed, what a deal :mad:

PlaneswalkerX
02-01-2011, 07:21 AM
I have a quest I have done already, but in my questbook it's still shown as a active story related quest (Green pin).

It's the quest where I have to get that dragontooth from a cave in Jurban/Erimos.
Earlier in the game i visited this location and found the dragontooth already. I think this glitched me.

chichan123
02-01-2011, 07:22 AM
The timer is clearly displayed at the top right of the screen in BIG fonts for both the quest you mentioned. I dont know how you didnt notice it.....even then there are 10 save slots....you can always reload a previous save and try again later.

Mr Magic
02-01-2011, 09:29 AM
For the Rustlers run you can just talk to the guy that gives you the quest and it will start again.

MADasaHatter
02-01-2011, 01:22 PM
For the Rustlers run you can just talk to the guy that gives you the quest and it will start again.

I can vouche this is true.

I tried running it at first (because I don't use a horse) and failed. I just ran back to the guy and tried it again.

There's another quest people on here say you mustmustmust save before and that's the Mage Guild (I think) quest named "Kaboom". It's a timed door or something (I haven't gotten that far)

Wardancer
02-01-2011, 09:14 PM
No, "Kaboom" is a quest for the Thieves guild and the one with the buggy door is a Mage guild quest. And yes, the problem is a door that closes automatically. It closes so fast that you are easily left on the wrong side of it, making it impossible to finish the quest. Luckily the game autosaves when you enter the cave where the door is located.

As to the original post: what do you think the save/load functions are there for?

JONBLEACH
02-01-2011, 09:55 PM
Its going to be hard for me to find where that guy with the race quest is again since i wont have a marker on my map.
I only have 1 save because it gets less complicated.
Plus i intend to make another playthru after im done my 1st but i want to try and get the most achievements i can on my 1st one.
I completed the Mages Questline and got the achievement but im still getting mage quests from the bulletin.


** Whats the name of the mage quest with the door that closes?

Buffmaster
02-02-2011, 11:47 PM
He's located in the small town on the water acroos from the lighthouse.

msc 10
02-03-2011, 01:08 PM
Missed a timed quest for the thieves achievement. I dont try it again