PDA

View Full Version : Wheel of Misfortune glitch?


SkyJin
03-01-2011, 01:09 PM
Hey, I went into Reaver's Mansion to do the quest which came with the Understone DLC. But everytime I interact with the wheel.. the door behind me locks and my dog disappears. Nothing happens and I can't get out! :( I have to dashboard in order to get out of there. Which is ok, but I wanna do the quest.

Anyone experienced this?

EDIT! Also the Shooting Range with Lemmy doesn't work either, is all Understone quests glitched if you haven't done them before getting Traitor's Keep DLC?

JunkieGamer
03-01-2011, 04:08 PM
same thing is happening to me. I think the dlc is a glitched up. so I hope there is a patch soon

SkyJin
03-01-2011, 09:30 PM
Same here! As I only did the main story quest in Understone DLC.. stopped playing it, but now that Traitor's Keep is out, I wanted to keep playing. So much for my fun, and my Demon Door chievo bugged out too! :(

Weapon X Death
03-02-2011, 04:10 PM
same thing has happened to me except its saved and now am stuck in tht room :( i cnt get out with fast travel or anything so basically am thinking iv got to start i new game which i really cba with :( any ideas any1?

niko da bos
03-02-2011, 04:32 PM
oo im glad i didnt spend $ on this DLC with all these problems im seeing :O

and it seems if they lock you in there AND save, there should be something in that room you need to do. its hard to believe they would just lock the door behind you, then save so you are trapped in a room lol. but ya maybe youtube the quest to see how others got past this part?

Prime-Directive
03-02-2011, 06:42 PM
i went to do the shooting range last night and as it started no targets would pop up, i had to button mash untill i got free only to find there was no one around, i left the region and it said leaving will cause this quest to start over bla bla and so i did and wouldnt u believe it, i now have to start the hole understone DLC all over again, which means Reavers manner and gaing those 2 weapons and everything, im so pissed about it, i mean ive always loved the fable games and i always will any time they release a new one but i fear ill have to keep playing under the pressure of anxiety that something bad will happen every game...lionhead do something about patching these games, or at least develop it over 3 years or so so its basically perfect instead of making me rip out my hair from rage >:(

ManekiNeko
03-02-2011, 08:46 PM
Exactly the same thing has happened to me, now I have no idea what to do, I went to select the wheel to do it but it disappeared and won't come back, now the door is locked. =/

xICooRsYIx
03-02-2011, 09:42 PM
This is odd.. I just did "the wheel of misfortune" quest and everything worked just fine... I also did "the voice" which is the quest in which you discover understone. I have yet to try out the shooting range, and now im a little hesitant..

I didnt get a "upgrade" popup when i put the game in either, so idk if any patches have been made.

Anyone else do these without a problem?

-xICooRsYIx

Nyzrizzle
03-03-2011, 12:20 AM
The DLC worked fine on my first save file. But when I tried it on my second save file, just like what happens to you the door locks me and the game reminds me to "Go to the Wheel of Misfortune inside Reaver's Manor". But the wheel has no option of selecting it like it did on my first play-through. I didn't save so I just have to quit the game to get out.

Talhiri
03-08-2011, 08:45 PM
I had/have the problem where I played the Wheel once and now can't replay to get the Dirty Harriet and it appears you can't trade those weapons from a different profile to another. Hoping for a patch or I dunno.

Cezzie
03-08-2011, 09:45 PM
I was fine with the wheel, I can't do the shooting range :(

Ragnarok1986
03-09-2011, 05:34 PM
I downloaded the understone Dlc second and everything works fine. But feel ripped off for 400ms points. Only took me 40mins to do it all :(

criffo
03-13-2011, 06:14 PM
I played through Understone without a problem. But after beating Traitor's Keep, I went back to the Wheel, and saved in the room where I'm not trapped. So ya...definately needs a fix. >.<;

Mattlus2002
03-14-2011, 11:22 PM
I've heard that this only happens if you have Traitor's Keep AND Understone.

I have both but have never done anything on Understone since I got Traitor's Keep so fortunately I haven't experienced any problems yet.

uglytruth
03-20-2011, 02:21 PM
I am also stuck in this room. It saved after I tried to activate the wheel and now a charater which has over a hundred hours of game time is lost. Thanks Lionhead, think I'm done with fable games. Bring on the Elder Scrolls