PDA

View Full Version : Stuck? Glitch right after the Baths (or maybe just stupidity) *spoilers I guess?*


Darkflame894
06-28-2007, 07:42 PM
I just completed the Turkish Baths (got the briefcase) and exited the way I came in, to the City Hall sewers. I see a door I think I should be able to open (it has a handle), but it won't budge. Did I even go to the right area? What's going on here?

IbdwIRascal
06-28-2007, 08:58 PM
Other than not going through the crazy man's place (the one who's heart gives you Blackhole), you go back out the same way you came in. Ending in the old abandoned City Hall subway station heading out back towards the Fulton St. Station. If that doesn't jog your memory, give a little bit more detailed description of where you are and we'll figure it out.

Oh - and from what I recall, the handle doesn't always mean that it can / will open. The one you're hitting may be one that you used on the way in (as a part of the crazy man's crypt) and may just be blocked off now.

Darkflame894
06-28-2007, 09:23 PM
I'm down at the entrance/exit to the baths, by the ladder. It doesn't look like I can jump to any of the scaffolds to get back up towards the City Hall station. Is there another path down here?

IbdwIRascal
06-28-2007, 09:38 PM
I think I know where you're talking about. Right after you jump down on the scaffolding on your way out of the Baths? If I remember correctly after you jump down you head right towards the bathrooms and then up into a big open area which then connects into the hallway you took the long way down to reach Looney Bin.

If I got the right area and the door to the right with a handle won't open then you might want to use Blackhole or something to the like to try and knock it loose. If that doesn't do the trick you may have to restart your box to fix it.

I'm going to see if I can get back there and check it out to make sure. Sorry I'm not of any more use.

Darkflame894
06-28-2007, 10:25 PM
Yeah, that door you speak of is the one that isn't opening, I'm pretty sure. I don't remember passing through those bathrooms, so maybe it glitched and won't unlock now. 'm pretty sure that door wouldn't unlock when I first came down of the scaffolds either. And I was enjoying this game, too...T_T

IbdwIRascal
06-29-2007, 03:15 AM
I didn't run through the bathrooms on the way in at all either. Have you tried knocking the door down or restarting your Xbox? It might be a while before I get back to that part to double check my memory, so hopefully someone else can try and pitch in as well.

Thickalicious
07-06-2007, 05:47 AM
This is the exact problem I am facing right now, I've tried everything. I even used the arm to drag the barrel over to the scaffolding to get up to the first level, then pulled the barrel up to there to try to get to the top ( took me about 20 min ) needless to say it didn't work. I'm at the end of my rope here, I really don't want to start over from the begining of the city hall mission.....really. I don't understand, it triggered the "ambush" cut scene when I went down the ladder, but much to my surprise, no action. I find it hard to believe that me and Darkflame are the only two that took the route we did (which seemed like the only one) to get to the baths and triggered this glitch. I have tried everything and still no dice. So I turned it off for now I have to sleep. If anyone can figure out a way to get out of this mess, other than playing this entire level over again, I am all ears. Pleease, pleeease, help us.

Thanks to anyone who can lend a hand.

Young Vice
07-06-2007, 11:24 PM
I had the same problem. I eventually got fed up with it and started Chapter 3 over. I got all the way back to that same part and out walks Emerson to open the door and let me continue.

I'm glad to know that I wasn't the only one with this problem. Hopefully and update is coming soon to fix the glitches b/c this isn't the only one.

Thickalicious
07-06-2007, 11:45 PM
I was afraid of that :mad:
I really don't want to do it all again.
I'm gonna try it again in a bit and if it's still stuck, I guess that's what I'll have to do.

findusdaniel
07-07-2007, 03:03 PM
Im stuck at the same place. I hate this game I got stuck a bit earlier in this game and had to restart. but now iŽll just quit

Gorjira
07-07-2007, 03:10 PM
I had no problems with this...I got through everything and managed to get down the ladder...Although it did take me a few days, had to have a few rests to before I went mad and quit xD but yeah...It was all fine with me.

Funky Sack
07-07-2007, 05:31 PM
i think im having a glitch with the side missions. the one for jimmy the grape. i killed the informant at the apartment and got the list he asked for, then when i went back and talked to him he told me good job but he never took the list. now all he says is "hows it goin?" and i cant give it to him. anyone else with this problem?

X blaze2
07-07-2007, 10:00 PM
It's not a glitch i don't think, it's just you need to run through a certain part of the rooms to get a save icon or the door won't let you through. I had to do it like five times before i figured it out. Besides that the only thing i can tell you is use all ladders you find and i the problem keeps up take the other advice and restart the game.

p4in redefined
07-09-2007, 03:29 PM
i had no problems with any of this i love this game!

Exane22
07-09-2007, 04:03 PM
The only reason that i can think of why this isnt working is that you killed the homeless guy who comes and open the door for you. If you didnt then ya its a glitch and its one im glade i didnt experience bc it would have definitely pissed me off.

codedigital
07-09-2007, 04:06 PM
i think im having a glitch with the side missions. the one for jimmy the grape. i killed the informant at the apartment and got the list he asked for, then when i went back and talked to him he told me good job but he never took the list. now all he says is "hows it goin?" and i cant give it to him. anyone else with this problem?

Jimmy doesn't give you anything. He's the only one I believe that you don't get anything from.




I never had any issues with getting out of that area.

Zoc
08-05-2007, 03:08 AM
i'm stuck at that place too, and the thing is that i did this part on the normal difficulty and i wasn't stuck. but now i did it on hard and the door won't open, i tried to get up the ladder to the turkish baths again to see if i killed every one but it didn't help and i remember that i didn't kill the homeless guy that opens it. Anyway it pisses me off that i have to start this thing all over again. hope it won't glitch again when i reach that part for the second time...

wakey
08-06-2007, 11:08 AM
Yeh im stuck here too, damn irritating, I'm hanging around for the patch due out this month hopefully that will resolve it. Tried looking for an official Forum too to post it to the Devs but the websites just FLASH with no forum or nowt :(

I was really getting into this game too dont know if i can be bothered to play through it again, fingers crossed for the patch i guess.

Zoc
08-06-2007, 09:26 PM
i just restarted the whole chapter, and since i had to restart i did the first part of hell again to get all the letters there, anyway when i got back to the baths part, emerson came through the door and everything was ok. i don't know why it glitched the first time...