PDA

View Full Version : glitchy achievements?


Lord Fordy
05-06-2011, 10:12 PM
been playing through the game normally, and looking at the achievements i should have unlocked "rampage" and "demon slayer" but neither achievement have unlocked
can anyone shed some light on this?

Didi Mau
05-07-2011, 07:26 AM
It's the first time I've heard of it happening for this particular game, and I've never had any trouble with them on any of my gamertags so it's probably just an unfortunate occurence that should be fixable through either deleting and reinstalling the game, or recovering your gamertag. I'd recommend doing both and then trying again (perhaps clearing your cache as well for good measure), it only takes a few minutes to unlock the first achievement so it shouldn't take too long to see if it's sorted.

One thing that has popped up twice recently with people however is that they've had a missing room not save on them once they found it, and had to go back and enter it again- once you get to the point where you're going to 200.6%, try to remember your final couple rooms in case you have to backtrack for some reason (or knock out the remaining handful in one session).

Lord Fordy
05-09-2011, 11:21 PM
still no luck with unlocking achievements, i deleted and reinstalled the game and just tried for the bloodlines achievement, nothing at all
im not sure if it'll work, but ill try recovering my gamertag later and see if its effective

btw am i really the only person to have had this issue?

Didi Mau
05-10-2011, 09:25 AM
Yours is the first post in this subforum about glitched achievements that I've read to my knowledge (though I may have forgotten one certainly), and I've been checking back here quite regularly for about a year or now due to loving the game haha. My suggestions came from a similar problem I read posted about the arcade title Altered Beast (link HERE (http://www.xbox360achievements.org/forum/showthread.php?t=307096&highlight=Altered+Beast+glitch)), where he was told to uninstall/reinstall the title, but eventually fixed it by recovering his gamertag.

Sorry to hear about the first method not working, if clearing the cache and recovering the tag doesn't work I'm afraid I'm out of ideas and you might want to consider calling Xbox Support :( Let us know how you get on, it'll be a real shame to miss out on this gem of a game.

Lord Fordy
05-17-2011, 07:32 PM
i finally managed to get the achievements to unlock
i deleted and reinstalled it earlier, and i noticed that there was a live update. instead of usually clicking yes i ignored it and now the achievements are unlocking (just cant go live while playing it, ah well a small price to pay)

anywho thank you again for the suggestions on how to fix the game, im now going to go play SOTN lol

Didi Mau
05-17-2011, 09:49 PM
Well I'm glad you found a fix at least! :p It's odd though, I wonder why it played up in the first place. Enjoy the game! :)