PDA

View Full Version : Glitched achievements


IC3 L3G3ND
06-13-2011, 09:27 PM
Im convinced there are 2 glitchy achievements.

Man At Arms
Goblin Hunter


I have 4 level 10 characters, i have my 24hrs achievement, I have beat the game 6 times i think, i have also played chapter 1 at least 12 times, I have spent over 1million gold grinding all different shops using chapter select and making sure to save and i still don't have them.

I also have every weapon in my inventory from the achievement guide and still nothing

Psycho Jesters
06-30-2011, 03:11 AM
I got those two just fine but I can't seem to get the 24 hour one beat the game four times and spent 14 hours hooked to a charger afk and still nothing. I did however notice the leaderboards only count your first play maybe that's your problem?

Sa666ath
07-11-2011, 07:17 PM
I have all characters to lvl 10, but don't have the achievement.

GENWAKU
07-21-2011, 12:53 AM
Three characters at level 7 and no goblin achievement. I've only ever played multiplayer, though, so maybe that's the problem because in the friends leaderboard section the number of goblins I've killed hasn't updated since I stopped playing single player where I racked up 600 kills and then got bored and started strictly playing with friends.

axeman430
07-21-2011, 11:42 AM
I have 4 lvl 10's. My total time is only around 5 hours. Anyone else having this issue? People seem to be having random issues about as random as which, if any, abilities are wiped off your characters... Anyone else got info?

TriRock
07-22-2011, 01:33 PM
I have all characters to lvl 10, but don't have the achievement.

The exact same thing just happened to me.

andy2k666
08-22-2011, 11:46 AM
i have the 4 lvl10 characters and over 24h gameplay but no achievements... thanks for the wasted hours.

MadWorldET
09-06-2011, 12:22 PM
The exact same thing just happened to me.

Grinding this game was hard enough will all of the skill bugs and what not....but getting all the characters to level 10 in this awful game and NOT getting the achievement makes me wanna go slap everyone involved in making this game. FFS I hope they fix this.

Jediboy2003
09-06-2011, 04:14 PM
I'm just curious, since you mentioned the skill bugs. Did you experience them at any time or any of the other glitches? I'm wondering if experiencing those is related to the achievements glitching?

I'm aiming to get my 24h played and last 2 level 10's today and hoping they won't glitch. I hosted my online matches and didn't hit any major glitches, and my single player seems to be going fine so far. So fingers crossed...

Update: Took longer than I had anticipated leveling my last two characters, but both achievements unlocked right when they should have. Might not be any help if you're already glitched on any of them, but hosting any co-op sessions you play or playing solo and doing the co-op run after getting all other achievements seems to be the safest way to go.

TriRock
11-09-2011, 10:09 AM
So, I finally got the Four of a Kind achievement. Here's how it went:

- Leveled all characters to lvl10. No achievement.
- Leveled first another fighter, then another cleric to lvl10. Still no achievement.
- Deleted save game, wiped cache. Started a new save game.
- Leveled first another mage, then another rogue to lvl10. Achievement unlocked!

At no point did I play co-op, not even locally with a 'mule' to transfer items between characters. I can't say this is a sure-fire way to fix things if you got shafted the first time, but it worked for me.