PDA

View Full Version : Mosh Pit Achievement Glitched?


xRyudo
11-20-2011, 10:59 AM
I've tried to do this achievement but it refuses to unlock.

I had AT LEAST 20 guards poisoned at once by gathering them all during Sequence 4 Part 1. (Where you have to beat up the Minstrels), but it still doesn't unlock.

Anyone know what I'm missing here?

zarda1
11-20-2011, 11:39 AM
you're using the dutura leathal bombs with the british gunpowder? if you go to fatih camii using the tunnel system climb on the roof of the mosque to the north with cherry bombs and the poison bombs throw one cherry wait for them to gather then throw another cherry there should be enough when you throw the poison bomb. it does look like a mosh pit.

xRyudo
11-20-2011, 02:36 PM
Yeah I'm using the correct bombs, it's definitely poisoning them. For some reason it's just not triggering the Achievement, even with 20+ guards in the vicinity.

I even copied a video I watched online and did it EXACTLY like in that video, and while it did pop there, it refused to pop for mine.

[Edit]
Figured it out. Turns out the Infinite Ammo cheat was turned on to get Inf. Bombs. Seems the cheats block Achievements as well besides not saving the progress.