PDA

View Full Version : "Call That a Challenge" glitched?


Streak Leader
04-19-2012, 02:10 AM
I have one time challenge left - Abysus. I have played through it (after finishing the game) TWICE (visiting the fella in the green suit to trigger the challenge).

Both times, I start with no timer at all. I finish the level and it lists my time as 0.00 and gives me the 1000 evo bonus, but no achievement.

Has this happened to anyone else? I will NOT play through this again from scratch. I guess I will mop up the other 2 achievements I need and move on...

Edit: I decided to start the time challenge for a 3rd time. Still no timer. I quit to dash, reloaded the game, started the challenge again, and BAM! there was a timer.

Just a heads up for anyone else that comes across this strange glitch.

Worhammer
04-23-2012, 07:28 PM
Thanks. Just rented this game, good to know how to fix it if I run into this.

Funny, it DID happen to me.

raidenhardcore
02-23-2013, 01:03 PM
I have some other achievements not unlocking while I just know I did them perfectly like Human Bullet and Bustin Some Punks wont unlock so far, also when I restarted checkpoint it glitched and had to quit out since I could not see my character and could not continue game is seriously glitchy

edit: got them all , for human bullet it was the last one I created a new game next try and got it

CellFrame
06-03-2013, 08:50 AM
Yeah, the same thing happened to me too. It isn't the achievement that's glitched, to be precise, but the challenge.