PDA

View Full Version : Level skip not working


Vivi
06-02-2012, 04:35 AM
ok so im horrible at this game and just want the beat all games achievement. I couldnt beat it even with the 3 or 4 continues they give you. The code is supposed to be ick a character then quicly press A,A,A,A,start,C,C,C,C,C. and yes im pressing X for A and B for C. tried like 10n times and it isnt working. :(

sdekaar
06-02-2012, 09:54 PM
me too.
strange in golden axe 2 it works.

Exu
06-02-2012, 10:51 PM
This cheat is notoriously difficult to get working, I only managed a few times on the MD/Genesis Collection disc. If you do get it working you won't be able to get the True Ending achievement though.

Vivi
06-03-2012, 04:51 AM
Thats fine, I'd just like to beat it so i can have the Beat all Games achievement. :(

VirusDave 138
06-03-2012, 11:39 AM
Ive beaten Golden Axe 3 Solo today with 1 Continue left!
The trick is to choose the upper path first, think its easier and every time you get a beast to ride on, use it! move very slowly trough the Levels then often only a few enemies appear, the rest stand still and attack when you come close!
Farm magic and safe it for the boss!

Worked fine for me!

Option 2, take a hostage and complete the game in Coop!

sdekaar
06-03-2012, 01:28 PM
option 3, abuse with save state.

VirusDave 138
06-03-2012, 06:40 PM
option 3, abuse with save state.

yeah, but this is pretty gay...