PDA

View Full Version : Turtle Beach problems?


SmorepionKid
07-05-2012, 01:41 PM
I just bought my Turtle Beaches 2 months ago and they worked fine, when I unplugged the audio cables the inside of the TR's L audio cable came out. Then whenever I turn my mike on it says I'm talking when I'm not, except in party chat. Now if I have my TRs plugged in or if they're off they say I'm talking when I'm not, my old Xbox 360 mic had the same problem. Has this happened to you?

ChickinOnaChain
07-05-2012, 01:48 PM
It's never happened to me but I don't plug and unplug anything on it. If it's only 2 months old, take it back to where you bought it and get a new one.

niko da bos
07-05-2012, 03:26 PM
It's never happened to me but I don't plug and unplug anything on it. If it's only 2 months old, take it back to where you bought it and get a new one.

i agree if its that new, i would take it to them. the least they can do is tell you maybe whats causing the problem, if it isnt the headphones themselves.

i know mine never had that problem, although most of the time i dont have that part plugged in. usually i only talk if im playing with friends or in party chat, so most of the time i just use them for soundwhoaring:)

mine have a switch (green / red) on the volume control somewhere on the wire. by switching it on and off, you can toggle voice chat on and off for the headphones. not sure if you're have that also, this is the first set i bought.

yourbreakfast99
07-05-2012, 03:30 PM
mine have never done anything like that. Which model do you have

SmorepionKid
07-05-2012, 04:27 PM
X12
And I think I lost the reciept also.

Ehrenfried
07-06-2012, 09:48 AM
I got a problem with my turtle x41

I can hear a crackle everytime i'm in the dashboard and moving the cursor.
If i'm constantly moving nothing to hear, except fot the usual sounds, but when i don't move it for 2 sec then the crackle is back.
In games it's not there.