PDA

View Full Version : Wonders not finishing being built


Bay Area gunner
07-17-2008, 04:19 PM
I have had this happen several times and it is extrememly frustrating. I will be building a wonder in one of my cities and it will get to the turn when it is supposed to be finished and will just disappear. It will not finish being built but will be unavaliable to build again. What is going on? Does anyone know how to fix this problem? It only happens when I am playing a regular game, but in scenarios.

eXtreme 1138
07-17-2008, 04:53 PM
Are you sure it has dissapeared, have you checked the buildings list on the city screen by holding down RT? If it really isn't there then I can't help you I'm afraid.

KabuKiArcade
07-17-2008, 04:56 PM
In my experience, that means another civ finished the wonder before you, OR it became obsolete and no longer available to build.

I don't always get the messages when another civ finishes a wonder.. I guess you have to have met them first!

-KabuKi

iskoot
07-17-2008, 05:53 PM
In my experience, that means another civ finished the wonder before you, OR it became obsolete and no longer available to build.

I don't always get the messages when another civ finishes a wonder.. I guess you have to have met them first!

-KabuKi
That's exactly what it is. If another civilization builds it before you get done building it then it disappears from your wonder list, though you DON'T loss the production that went into the wonder. Also, if you don't know them then the game doesn't tell you that so-and-so civilization build this wonder, but if you have met them then the game will tell you.

plumbpist
07-17-2008, 07:10 PM
Kabukiarcade is correct. it happens alot! very frustrating...

Bay Area gunner
07-17-2008, 08:11 PM
I will completely lose the production and the wonder. I have never seen the message that says someone else has finished it when this happens. I thought it was a glitch or something. Anyway it seems like whatever is happening there is nothing I can do to fix it so it is no biggy I guess.