PDA

View Full Version : NO World Bank in Civilization Revolution *WITH VIDEO*


CaptainKicker
07-22-2008, 11:08 PM
Ok my problem is.. Im over the 20.000 gold you have to achieve before you can build "WORLD BANK" for an economic victory.

Watch the video, if you want to see the problem:

Im Spain
Im playing a normal game on King diffuclty

Are there something i forgot to do?

YOUTUBE VIDEO:
YouTube - Need help: World Bank in Civilization Revolution (Xbox 360)

KabuKiArcade
07-22-2008, 11:46 PM
That's pretty odd, but I do notice if you are over the 20,000 the economy bar should be 100% to the right of the screen, not on the spot before it. In fact it says you are at 7 out of 8.

Maybe you have too many units? As I recall at 10,000 gold you get a great person bonus, if he never spawned that could be why your screen it stuck at the 10,000 goal instead of the 20,000.

-KabuKiArcade

REDBEES
07-23-2008, 01:22 AM
this happen to me one time with the united nations building, I had gotten 20K previously and the world bank was buildable, but when I got the the 20 great person mark, I could not build the united nations. Was annoying, but I played again and it worked fine.

STBadly
07-23-2008, 02:33 AM
It happened to me too a week ago. I just had to start over, because even loading a earlier save didn't work for me. Sorry dude! (or dudette)

G315T
07-23-2008, 12:32 PM
I've had it happen a few times where I'll meet a condition, but I have to wait 2-5 turns for the UN or the WB to actually show up on my build list. Dunno if that'll help you, but that's all I've seen.

CaptainKicker
07-23-2008, 02:34 PM
Well this is the SECOND times this happened, and i actually played over 30 turns after this video was captured, and still no World bank..

xepherys
07-23-2008, 07:04 PM
Odd, I've been able to build both and not had an issue. Bug report with 2K / Firaxis? I'd recommend it.