XboxAchievements.com

XboxAchievements.com (http://www.xboxachievements.com/forum/index.php)
-   Lost Odyssey (http://www.xboxachievements.com/forum/forumdisplay.php?f=381)
-   -   The Fatidic Treasure Trove Achievement (http://www.xboxachievements.com/forum/showthread.php?t=351965)

Arkstrife 01-08-2012 04:46 PM

The Fatidic Treasure Trove Achievement
 
I will tell you all a little story:

I bought the PRIMA guide and complete the game 2 years ago leaving it to 980G due to errors in the guide, which more later i search (burning cave, Gongora mansion and crimson forest) but still did not have the achievement, this put me anger and I deleted the saved game .

1 month ago started again with revived strength and with the guidance set out here printed with pen and crossing out every object that was (looking at the PRIMA guide maps to help)

What was my surprise that after all the fucking cross list (including underground treasures, Tolten seals, invisible treasures and treasure hunting, etc ...) the achievement did not pop up

Anyway, I have a couple of theories:

The first is that not all coins collected soil and opened one of the chests before facing money-money but say that does not count for achievement because is disapear later, (someone can confirm at 100%?)

The following theory is due to all those people who says he has followed various guides (youtube, the one that splitplaytru, etc) that says he has not pop up the achievement, I think some people myself included have the achievement bugged and can't do it (IS THAT POSSIBLE?)
Some people who says that it will repeat again for other forums, i search their GT recently and some of theirs still with 980G (really bug or abandoned try?)

Yesterday and today I'm reviewing the whole guide of the forum place to place, and i tell you later if works for me or not...

Any idea what ever happened to me?
Anyone have the same problem?

Arkstrife 01-08-2012 07:31 PM

I'm Just finnish the 2 check of the forum guide.


I'm almost sure that the achievement it's bugged and can't be repair.

Adding these, i have read some comments at splitplaythru video guide (www.youtube.com/watch?v=3xO1DByrb0A) that says they follow for 1 to 1xx video and didn't get the achievement and after this... i thrust them.

Anyone know something about these?


(Last chance is get New Game+ and follow splitplaythru guide, but i hate this game hardly right now :mad:)

o0ArA0o 01-08-2012 11:35 PM

I followed the written guide from SplitInfinity and Treasure Trove unlocked when it should do. I read about something that a few items are missing in the PRIMA guide ... but I think that are the errors you mentioned. So I dont know what that game is doing with the people, I got a glitch like you see in my other thread that most likely no one has ever seen before too.

I think cross checking your list with the written guide from Split could maybe help you seeing what you could have missed or if its really another glitch. :/

The Pants Party 01-09-2012 12:43 AM

I used the guide stuck at the top of the forum (link below) and got it on my first try. Hundreds of other people on this forum did as well. If you pick up every item listed there I guarantee it will unlock. The achievement is NOT bugged.

http://www.xbox360achievements.org/f...ad.php?t=63877

Arkstrife 01-09-2012 10:51 AM

as i mencioned before, i follow religiously the guide stuck at the forum, cause i know it works, and i follow it 2 times, printed list, and crossing with a pen 1 by 1 all of the items, first when i pass the game and second time re-cheking all places again, (and no items at the auction), but the achieve doesn't pop up.

I'm not saying that the guide is wrong, i've done tons of achievements like this (assasin creed, gta IV, all call of duty's collectibles, full blue dragon) and always doing for the first time, tons of printed guided marked, im always sure what i take and what not, and save game in separately slots frecuently.

This is (and for the people who follow splitplaytru and didn't doing too) cause i think the achievement is bug for some people.

Anyway i will follow AGAIN all places these days and if doesn't work, i will do new game+ and re-do again with 3 distinct printed guides and splitplaytru youtube's guide, and then i will come back and tell all of you.

I know, i'm crazy... it's only 20G, but... NOW is PERSONAL :mad:!!

o0ArA0o 01-09-2012 11:28 AM

Quote:

Originally Posted by The Pants Party (Post 4813944)
I used the guide stuck at the top of the forum (link below) and got it on my first try. Hundreds of other people on this forum did as well. If you pick up every item listed there I guarantee it will unlock. The achievement is NOT bugged.

Hundreds of others would say that the Skill Master achievements arent bugged too ... but for me in some weird way they are (Mental Stability 2, other thread, you know ...). So I believe this guy and think something is wrong with this game, I just didnt know what triggers these glitches.

Arkstrife 01-09-2012 03:18 PM

Yeah, i think o0Ara0o problem and these problem, the 2 achievement is relationated by some way, i've read tons of people who pop up TT and doesn't pop up Skills achievement and people who have Skills and doesn't pop up TT and all of them confirm that they follow the guide... (most of all the youtube guide of splitplaythru)

Yes, i's easy to fail a item but, the skills??

I can't confirm at 100% but day a day, and forum a forum i realize it may be true.

thecallahan 01-11-2012 03:49 PM

I didn't get the Treasure Trove achievement either but in the next few days I'm going to go back to old dungeons to see if I accidentally crossed something off the list when I shouldn't have. I've read that most people messed up in Ipsilon or Uhra when it came to item gathering so I'll be starting there.

Headless Snip3r 01-12-2012 12:11 AM

I'm 99% sure that I got everything in the game by crossing it off 1 by 1. Gonna sit down and grind out the skill achievements for all of my immortals tonight. I'll post back with an update on that. Then I'll start at Uhra's Gate and do every area again. My auction house says closed, so I assume that means that I didn't miss anything in the non-returnable areas. I also didn't pick up all of the gold trail dropped by money-money (had over 800,000 at the time, so didn't see the point).

Headless Snip3r 01-15-2012 11:53 PM

Went back through my game, and yes, I had every single item. I saw in another thread that possibly the money-money 1g drops counted. So, I started over and played all the way through the game again. This time I did 2 things different. 1. I picked up the light lens in the cages after being captured at grand staff and 2. I picked up all of the 1g drops from money-money. When I got to the end, and picked up the last item my achievement finally popped. Seems that these two items are likely very important, but just failed to get into the guide.

How to get the light lens is simple when you know how. It is timed though, so you'll need to be quick about it. *SPOILERS*!! When you are all captured and in seperate cages General Kakanus will come and speak to you, and then you have control of Kaim. Do the following to get your light lens, and hopefully put you one item closer to Treasure Trove.

1. Ram the door with Kaim
2. Switch to Jansen
3. Don't ram the door. Investigate the SW corner to find a rat with "something" in it's mouth.
4. Kick it
5. Switch to Seth
6. Don't ram the door. Investigate the same spot you found the rat in Jansen's cage, and kick it.
7. Switch to Kaim
8. Now you can get the Light Lens in the same place as the rat. If I remember correctly it is a glowing thing on the ground.

Good luck, and I do hope that this helps anyone going for this achievement.

Arkstrife 01-16-2012 10:16 AM

Yay thanks for the tips Headless Snip3r

I will begin new game+ and doing those 2 things you mencioned (just the 2 i left too in my game)

if it works i'll tell to confirm.

:)

msh412 02-24-2012 02:36 PM

Arkstrife, I think I'm having the same problem as you. Did you ever get the achievement? I followed the walk-through religiously when I was playing. I have double checked everything several times, yet still no achievement.

Arkstrife 02-29-2012 12:15 AM

Still on it, this time will take long time but i will post whenever complete.

(Only hope get the achievement this time but...)

Tsaako 06-03-2012 02:26 AM

Theres a nifty checklist around these forums somewhere. I'm sure you could probably find one off a google search.

I once had the problem of struggling to get treasure trove. Then someone introduced me to a video guide that had included all items that you could get.


Arkstrife 08-22-2012 03:52 PM

Hello again m8's

I'm going to doing again all game following the guide & video guide of splitplaythru with new game+.

In adition i'll follow the Headless Snip3r recomendations and then, i will tell all of you if the achieve pop up or not.

See u soon!

Supah Sage 08-27-2012 02:23 AM

I also got screwed years ago on the Treasure Trove achievement. Just went through again and crossed off EACH ITEM one at a time on the guide listed here on the forums. At the end, I had four items at the Saman auction house that were from "Somewhere off the coast of Numara." I believe they were somehow from the Arthosaurus mini-game. Purchased all the items at the auction and still no achievement.

Supah Sage 08-27-2012 07:35 PM

UPDATE: I went through my item guide and decided to back clear any area where I had handwritten a notation on the guide.

Crimson Forest: Near Swamp was first. I had written a note saying "Pillar", since I had rammed a pillar and wasn't sure which one to cross off yet. Apparently I had decided that I had found everything and marked that area as clear. Went back to the "Near Swamp" area. It was all the way north west, just out of camera view. Had to pan the camera left to find it.

I know odds are slim anyone else made my mistake too, but hope it helps. Achievement Unlocked :)

Northside 12-15-2012 10:32 AM

Quote:

Originally Posted by The Pants Party (Post 4813944)
I used the guide stuck at the top of the forum (link below) and got it on my first try. Hundreds of other people on this forum did as well. If you pick up every item listed there I guarantee it will unlock. The achievement is NOT bugged.

http://www.xbox360achievements.org/f...ad.php?t=63877

Totally used this guide went throught every place checking 1 by 1 i only missed like 5 items in my guide and they were easy find at the pirate fortress the ipilision mountains and i think a few things in the town spent 7 hours running around for 5 items now i can move on to vesperia

Elekid 05-04-2013 12:20 PM

You guys should also consider getting a silver XBL Japanese account so you can download the free DLC for the game that gives you Weapon Guard 2. That is a godsend, especially if you're speeding through the game like I am in order to acquire all of the items needed for the achievement. You save time with this equipped because it'll negate just about any damage taken; not every time, but quite often. You don't sit there after battles so much trying to get everyone back to full health.

Darc Jak 01-28-2014 04:07 AM

Okay, so after all these years, I finally decided to go ahead and finish this game. After a grueling extra 40 hours of searching everywhere for my missing items, I just couldn't get my TT and final achievement. After taking a week break to play a little FF XIII-2 (with Lightning Returns FFXIII-3 coming out soon), I decided to put it in and try some more. FIRST damn place I look (Temple of Enlightenment), which I was putting off because I HATE the damn temple areas in this game, I find a chest I missed somehow. I was using the shitty Prima guide on my play through and used Achiever TM's guide to go back to look in places and couldn't find it anywhere. Turns out I missed the ?x6? Gravestone of Fears in the top left corner of the first room. I unfortunately was so excited I found the last item I burned that crappy guide and now I can't check if the item was missing in the guide. O.O I thought I'd post to tell people that the places you are putting off is probably where they are, lol.


All times are GMT. The time now is 07:14 PM.

Powered by vBulletin®
Copyright ©2000 - 2014, vBulletin Solutions, Inc.