View Single Post
Old 01-10-2013, 12:55 AM   #8
Nevaeh 2Die4
 
Join Date: Aug 2011
Posts: 23

Nevaeh 2Die4's Gamercard
hey lads, i tried what you said still no luck,

seems im not the only one with this issue someone on the far cry forum posted this

A Connection To The Past *bug*
I've tried several times now to complete this quest. Simple enough; go find these tablets at these 3 locations and bring them back. My first attempt was fine up until I tried to grab the tablet you start closest to. I didn't get an icon to pick it up no matter where I stood and had to restart. No biggy, these things happen. Only now every time I go back to try and attempt the quest again, one of the tablets just isn't even there (this is the one the furthest from you just up the road a ways). I think this is about my eight or ninth try at this and as I couldn't find any posts relating to this particular problem I thought i'd report it and see if there is a way to fix this on my end, or if i'll have to wait for some sort of patch to address the issue.
Nevaeh 2Die4 is offline   Reply With Quote