View Single Post
Old 04-02-2013, 05:52 AM   #4
TheSaferHouse
 
Join Date: Jan 2010
Location: Oregon, USA
Posts: 190

TheSaferHouse's Gamercard
Just found this possible fix on the Ubisoft forums, going to try it now and will update when I know more...

"The workaround provided for Xbox 360 users worked out! I confirmed it earlier today.

I first deleted my DLC save file in Assassin's Creed 3. Next I went to the Xbox dashboard, navigated to the storage file for Assassin's Creed 3 and deleted the DLC episdes one and two, the save files, and the title update to the game. After that I started AC3, went to the Tyranny of George Washington and only downloaded the first episode. After I made it all the way back to the Justice Served mission everything worked and I made it past the bug. Hopefully this works out for people. If it doesn't I hope another workaround or fix is discovered soon."

EDIT: It worked! Thank god, it effing worked. My sanity has been restored. What a maddening glitch.

Last edited by TheSaferHouse; 04-02-2013 at 10:06 AM.
TheSaferHouse is offline   Reply With Quote