Jump to content

 

Dark Souls on Windows 10 GFWL can't sign in or save


JustinSane
 Share

Recommended Posts

Hey Guys, I'm at my wits end here. I'm using Windows 10 and bought a Dark Souls Prepare to Die Edition Disc version with the old Games for Windows LIVE banner on top (to get the achievements offline) but can't get it to launch the client for the life of me. Tried everything in every possible way but the GFWL program still doesn't work.

 

Dark Souls PtD itself runs almost without problem in compatibility mode for windows 7 (instantly crashes in native windows 10 for me), only thing is I can't sign in because the client doesn't start with the game, and the LIVE option in the main menu doesn't work. It also doesn't let me sign in at all to at least save my game.

 

Already installed another client from my old Fallout 3 GFWL Disc and tried it out there, the client opened without any problem and it prompted me to put my Fallout CD key in there. After that trying out Dark Souls again, just for it to show me another new error (couldn't find ordinal 5297), so tried repairing it to no avail, and after de- and re-installing it still doesn't open the client or letting me sign in.

 

One video was a guide about fixing this with some xlive.dll from SysWOW64 where he copy pasted the files into a "binaries"-folder for his Batman Arkham City to work, but no such folder exists for my Dark Souls problem.

 

 

Anyone got a similar problem and got it running?

 

 

TL;DR: Bought an old Dark Souls disc for the achievements, can't use Steam version. Using Windows 10; Fallout 3 opens the Client without any problems.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
  • Create New...