Jump to content


Can’t progress Tutorial - Story Mode


Recommended Posts

Having an issue in Story mode where I can’t progress past the instruction to throttle up.


I selected Imperial.

Changed control setup.

Press A to get in ship.

Press A to boot up ship.

Press LS to target.

Press RS up to throttle up.

I go nowhere.


I tried on default controls as well but still nothing. I also have played a multiplayer match and the controls work fine.


Has anyone encountered the issue and know how to fix it?

Edited by BluWolve
Link to comment
Share on other sites

  • BluWolve changed the title to Can’t progress Tutorial - Story Mode

I had a handful of bugs with the missions where the next objective would not register. I tried restarting check points and sometimes that worked. Usually I had to restart the whole mission. The part where I have to chase the fighter in the prologue it would just sit in the tunnel area. I could kill it down to one health and it would regenerate. 

Link to comment
Share on other sites

  • 2 years later...

I eventually did find a workaround, so if anyone else has the issue here is what i did to make it work;



Press pause and navigate to control options. All the way at the bottom is "Game Pad Throttle Input Mode". Change that from dynamic to static and you should then be launced forward out of the hangar. Then press pause and change it back to dynamic.


Hope this helps!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...